Style Designer: "Visted Link" color

  • 1
  • Question
  • Updated 5 years ago
  • Answered
The initial link color is working well. So is the hover color. However, visited links are not changing to the "visited link color" I have specified in the Style Designer. What am I doing wrong?
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
  • puzzled.

Posted 5 years ago

  • 1
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi maxxish,

It sounds like you are doing everything right as long as you are making your edits in the Style Designer and not within each individual text widget. We are happy to take a look for you if you can tell us the color code you selected for your visited links.
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
Hi Laura

Thanks so much for your reply!

The site is lisaenglish.yolasite.com.

Link color = #12a392
Hover color = #e6af19
Link visited color = #b50b30

I appreciate your help very much.

If you need more information, please let me know.

With thanks
Lisa
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Lisa

The most likely cause for this is that you are using inline formatting that conflicts with the formatting set in your Style Designer. The reason we have added the Style Designer is to allow you to have greater control over the look and feel of your site and get a more consistent result when editing text in the page.

The quick way to resolve this is to go to Style > Style Settings > Style Designer. Set up your default settings including text colour and size so that all of your paragraph text is a consistent colour. You will then be able to edit text without having your visited link font colour change when you do inline formatting.

To clean up any existing formatting issues, go into your Text Widgets, highlight the text and click the "Remove Formatting" button in the Text Editing Toolbar (second last icon next to "HTML"). You may then need to re-add links. I've created a test page which is a duplicate of your "about-lisa" page, and your link settings added to the Style Designer work on this page fine. You can remove this test page at any time yourself, and it's not published or in your navigation.
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
Thanks Stefan (and Laura)!

You are two of the reasons we love Yola - professional, responsive support!!!

Very best regards
Lisa
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
Hi again Stefan

So, I went to the test page you added (thanks). I used "Preview" since I can't get to it another way.

The c.v/resume link was turquoise, rolled over to yellow/golden, but did not turn red (visited) after being clicked.

Perhaps it's my computer?

Thanks
Lisa
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hm, that is odd. When I view your page in Preview and click on the link, it turns red when I go back to the Preview page.

Can you please add a few test links to that page? Make them link to one of your pages. Then preview and test again.

What browser, browser version, and operating system (e.g. Windows 8, Mac) are you using?
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
Thanks, Stefan.

Ah! The old "depends on which browser you are using" trick!

Sorry, I should have checked this myself first. Hopefully, I will be smarter next time.

My operating system is Windows 7 Home Premium.

I usually use Firefox (it currently says Firefox 23.0.1). However, I also have Explorer. Following your last comment, I opened the test page you created with Explorer ... to see that the link, does indeed, turn red!

I am calling this "solved" for now. In general, Yola does a super job of making sure that all its great features are compatible with the different browsers (which keep changing their versions as well). I think we can let this relatively minor item remain as is.

Great appreciation for all your help and patience!
Lisa
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Thanks, Lisa. That is now really odd because I'm using the exact same system, also Windows 7 and FF23. Cheeky Internet Explorer seems to turn out to be useful for a change, I don't mind that at all! :-)

However, it should be working in your Preview. The main thing is that it at least works on your published site. So if you want to test it, please republish your site, clear cache and cookies (which is another old trick ;-)) and check the test page which should be available under your domain name plus /about-lisa-test.php.
Photo of maxxish

maxxish

  • 19 Posts
  • 2 Reply Likes
Doesn't work when using Firefox even if I include it in the navigation and publish, but as I said, not worth the hassle.

Cheers!