Text editor in blog seems to be acting weird

  • 1
  • Question
  • Updated 8 years ago
  • Answered
Whats up with the text editor in the blog section? i['ve been trying to do a simple blog post for over an hour and the editor keeps messing things up. I don't remember it being this flaky before. I've used it a few times in the past, and while the editing features are somewhat limited, it at least worked correctly.

When I highlight text and go to change it either nothing happens or it changes all the content within the blog. I tired enlarging specific lines, add color and make things bolder, it seems I can only do either or, and not multiple functions. Even though I know I've done it before.

Weird, did something change within the text editor for the bogs?
Photo of Hatcheck Girl

Hatcheck Girl

  • 70 Posts
  • 2 Reply Likes
  • frustrated

Posted 8 years ago

  • 1
Photo of Kershnee

Kershnee

  • 2087 Posts
  • 152 Reply Likes
Hi,

Apologies for the delayed response. The text editor for the blog has not changed. Please can I have the URL of your site so I can investigate further.
Photo of Hatcheck Girl

Hatcheck Girl

  • 70 Posts
  • 2 Reply Likes
Hey we all gotta sleep right?

http://sitebuilder.yola.com/ide/index...

If that doesn't work try http://www.backyard-buddies.com/news.php
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello Hatcheck Girl

Thanks for sharing the URL.

It appears that you have text copied and pasted from MS Word onto your site. I need to advise you that when you copy and paste rich text directly from MS Word (or another word processor) onto your site, this brings along a whole lot of unwanted formatting that is not web friendly and can easily break your page. It can also cause your site to show up inconsistently in different browsers. The problem might not always show up immediately, but sometimes it happens after you save and navigate to a different page or log out and log in again. To avoid display and loading issues, the best alternative is first to paste your text into NotePad (in the accessories folder of your computer) and then paste it as plain text onto your Yola page. You can then use the Yola text editor to format your text as desired. Please note that this would be the case with any browser-based text editor you might use, not just Yola. It is a universal website building problem.

It's also always a good idea to keep a copy of your text in a .txt file from Notepad so that you have a backup copy kept on your PC.

The solution in this case - you can delete the page or delete the existing text and then re-add it to your page following the steps above.

For more information on why your site might not load in the site builder and what to do about it, see this tutorial. You can also use this Text Editor to format and spell check your text and strip out MS Word code. It will generate valid markup which you can safely paste into the Yola site builder.

If this doesn't solve the problem, please let me know.
Photo of Hatcheck Girl

Hatcheck Girl

  • 70 Posts
  • 2 Reply Likes
Re did it again in note pad all is right - my mistake I forgot we don't like MS code. LOL
Photo of Brianna

Brianna

  • 2045 Posts
  • 92 Reply Likes
Great to hear it is working properly, Hatcheck Girl!