The contact form goes to yola and not the sender

  • 2
  • Problem
  • Updated 6 years ago
  • In Progress
www.theelms.biz - when we get the contact form the default is at yola@no reply which comes back undeliverable - it should go to the person sending the e-mail.How is this fixed? Thanks

dufftown@hotmail.com
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
  • sad

Posted 6 years ago

  • 2
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
Click Edit (top left of the form) then settings, and change the address to your own e-mail.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
I did this - the form comes to our correct e-mail address as it should, the problem is that when we hit reply to the e-mail - it goes to noreply@yola which does not work. The form should go directly to the person who sent the e-mail..do you understand my problem? Thanks
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
Yes, I do. Sorry. Let me think...
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Chris

If you click on the reply button of your e-mail programme to reply to a submission notification, it is expected behaviour that this will create an e-mail to no-reply@forms.yolamail.com because the notification was sent from that address.

But when you look into the e-mail message, you will find the sender's e-mail address as a link (provided they have given their e-mail when submitting the form on your website). If you click on this link, your e-mail programme should create a replying e-mail window or tab where the sender's e-mail will be displayed as the recipient. From there you will be able to write your answer to the sender and send it off.

Hope this helps!
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Here is what we got this morning:
You received a Contact Us submission from The Elms Bed and Breakfast:

Name Fortier
Email Antoine.fortier@yahoo.fr
Phone
Message Dear Sirs, Could you please confirm whether you have a double room (ensuite) available for my wife and me on June 8 ? Kind regards,

The message comes in plain text and does not provide a link to the e-mail.
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
This could probably be done in Javascript, if you can find someone to write the 1 or 2 lines of code for it. (offers?)
Until then, you could include in the message section "If this email requires a reply, please add your e-mail address" or something.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Hello again - I noticed in the above that the e-mail address changed to a link but this does not happen in our e-mail. It just shows up as plain text with no link.
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
That's only peculiar to this Forum: it recognizes links. Your e-mail body won't.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Chris

The reason for this may be a default setting of your e-mail programme. If one of the settings for the format of e-mails says something like "plain text", and "HTML" or "rich text" are deactivated, none of your incoming e-mails will show any links the sender added to the body. Which e-mail programme are you using? Do you read your mails online (which provider?) or do you download them via POP3 or IMAP to your e-mail client, such as Outlook?
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
I have checked all the settings that I can think of and no luck. I am using the standard windows live with a hotmail account. I read my e-mails on line as we get messages in our inbox.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Chris

Could I do a test for you?

I'd like to send an e-mail to your hotmail account and include a link into the body text. You will then be able to check in your hotmail account if the link is displayed and you can open it.

Please post your hotmail e-mail address here or let me know your URL if you use your hotmail e-mail address for logging into your Yola account. Thanks for working through this with us.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Thanks for your help. The website is www.theelms.biz and go to the contact form and submit. The e-mail form goes to dufftown@hotmail.com

Thanks
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hi Chris

I've just sent off the test e-mail. Subject: Test mail by Yola support.
Please check your spam and junkmail folders if you can't find it.

When you've got it, open it and see if there is a clickable link in the e-mail body area. Keep me posted.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
The link in your e-mail brought me to the Elms website - when I went there and submitted a form - below is what I got - the email just shows up as text.
Now the last time I replied the e-mail address showed as a link in my replay after I submitted it - but it is just showing up as dufftown@live.ca with no link

thanks again

You received a Contact Us submission from The Elms Bed and Breakfast:

Name chris
Email dufftown@live.ca
Phone 1234
Message test
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
AGain - the links show up above but not in my contact form
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hrm, what a tricky problem. Ok, last thing we can test:
  1. Please go to your contact form settings and change the e-mail address under the settings tab to naffic@googlemail.com.

  2. Save and re-publish your website by clicking on the green Publish to the web button.

  3. Wait 10 minutes. Then clear your cache and send a form submission from your live website. It should now arrive in my e-mail account. This will give me the chance to check if I get a link.

I will keep you posted.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
I have solved the problem in another way - I have deleted the contact submission form and changed it to a text box with a hot e-mail link that works. It must have been something to do with the form.

Please go to www.theelms.biz to see the new contact us sheet - this works and will suffice for now

Thanks
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Ijust got your e-mail so will go back and do what you suggest - let me know how it works - I will change it to you, publish it and then change it back in case we get any real bookings!
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Sorry, but I cannot do this at the moment - will have to try again another day

I will let you know how I get on for now.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Chris, you won't need to do this in your real Contact Form. What you can do – if you have the time – is this:
  1. Create a test page: Page > Add new Page, name it "test" and uncheck the box for "Display in navigation".

  2. Drag and drop a Yola Form on this page and change the e-mail setting to my e-mail.

  3. Save and re-publish. The test page will not be visible in your navigation, but you can access it using the URL. If you named the page "test", the URL will be http://yourdomain.com/test.php

  4. Send a form and let me know.
Photo of user1202190

user1202190

  • 5 Posts
  • 1 Reply Like
Hello,

This is a really annoying problem, It would really help if you could change the system so that the email address entered into the form is the reply-to address.

Our other website is on Office Live and their forms do this, so its confusing employees and leading to them replying to dead email addresses. This has caused lost work and annoyed account holders.

I'm sure it would not take too much to change it and it would really help.

regards

Liam
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Liam

Thank you for your comment and feedback. This is a very good suggestion to make things easier, so I will definitely bring it to our designers' attention. I cannot promise we will introduce it, but we will discuss it.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Interesting that I am not the only one with this problem. My browswer supports interactive live so that anytime a www. or and e-mail address is typed in it becomes active. The only time that it does not do this is from my contact form in Yola. I have deleted the contact form for now and just put a direct e-mail link so that we get the senders e-mail address when they send the e-mail, but they do not include all the info on the regular contact form and it allows others to see our e-mail address. Hope you can sort this out. Please respond to this forum when sorted so I can go back and put the contact form on my website

Thanks
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Chris

Apart from your and Liam's suggestion to improve the reply functionality (thank you for that!), please remember that I was offerring you in my post above to check the problem for you. If your browser supports links in e-mails as you said, it should work on your side as well. We haven't had other users who complained about the e-mail link in the body text not working, and it has been working for me as well, no matter if I read my e-mails online or in Outlook.

So if you're still interested in trying to solve the problem, please follow the suggestion I made in my post above, and we may get closer to solve the problem. Thank you for your cooperation.
Photo of Chris Brousseau

Chris Brousseau

  • 14 Posts
  • 0 Reply Likes
Hi Stefan: I will give it a try - just really busy for the next day or two. This is a strange one I have to admit. Thanks for your patience.