Using the File Manager

  • 1
  • Idea
  • Updated 9 years ago
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes

Posted 10 years ago

  • 1
Photo of Peter

Peter

  • 2569 Posts
  • 113 Reply Likes
refresh
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi, I'm trying to organize my file manager, I've copied pics into a new named folder, here is where I'm getting lost;

Please note: If you move your files from one folder to the next or basically change it's location, and your file has already been added to a page on your site, you need to follow these steps:

* Click on "Edit" on the top-left of the file.
* Navigate to the file in your File Manager.
* Click on "Select".
* This will ensure that the correct path is being used for your file.

from the above tutorial, I'm not seeing the "edit", or maybe I should ask top left of which file? This part has me confused.
Also when I did the cut and copy into new file I get some a few images of the photo, but I'm getting a greyed box with a pick of like a camera and a small line below.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Rizan

Let me see if I can help clear this up for you.

Let's say you used an image icon from the right-hand side and inserted an image called "flower.jpg". This file's location was "resources/flower.jpg". Then, later you decide to move that image to a new folder entitled "scenery" and now the new image path is "resources/scenery/flower.jpg". Now the image that was originally on your site may appear as a broken image because the location of that "flower.jpg" has moved. So, on your site builder, you will need to click on "edit" on that image widget box and then follow the above steps given.

Does that make sense? Please let us know if we need to further clarify things.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
hope this screen shot works, now I'm getting red X's , should this be happening? Thanks.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi littleus, I wish I could say it made sense but, it doesnt. I go to the widget box (where there is currently a photo), I right click edit, nothing happens. So I open file manager, go to the new file I've created but, there is no select. This is probably the simplest thing in the world but has me totally confused.
Also, what of the red X is that normal? Thanks LU.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Ah yes I see what your saying now, I usually use the "insert image" up at top not the image widget. When I switched over and used the image widget I was able to walk through the instruction! These options I dont have using the "insert image".
Still a question though about the camera looking thing and the red x.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi Rizan - thank you for posting the screenshot. Could you let us know whether the images where showing in the first section of the File Manager before you copied and pasted them into the folder? Could you also let us know if you deleted any other files that may be related to this one?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Marije, the files at the top dont seem to have a file extension as the lower images do. Perhaps this is the issue.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Thanks Lee, you've helped me to identify a bug :) When you have a cropped banner image in your File Manager and then move it to a folder, the filename changes. We've logged it and will fix it as soon as possible. In the meantime, the workaround would be to rename the broken image back to its original name (right-click > rename) and it should show.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
My apologies, renaming the file doesn't seem to work, we will try and get this bug fixed ASAP.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Glad to be of service. :)
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi Marije, yes they were showing no problem in first section of file mgr. I actually did delete the pics as well from the first section of file mgr. I played with this one because I only had it in one banner so if/when I lost it it was only 1 banner to fix, no problem. I also created 2 other files one named "pyramids" the other egyptian bakers same problem with these files as welll. but, these I did not delete from first file mgr page. Thanks.
Photo of Kershnee

Kershnee

  • 2087 Posts
  • 152 Reply Likes
Hi Riza22,

The reason your images are not displaying is because you have some special characters in your file name. The characters are ",-"
Simply remove these characters and your images will load properly.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Thanks guys.
Kershnee, that makes sense, this started about 5 days ago, when I view rename and close I get "name entered contains invalid characters" this is just viewing not making any changes.
When I attempted to remove the ,- which is actually a ,. in the name field, what I'm actually seeing isnt same as cut and paste. I get an error that "rename has failed" and a box opens with "something has gone wrong" Additionally I never added these characters to the names of the pic. The only think I've started changing is from jpg to png due to other banner problems I was having. Thanks.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
LU, I just may continue to live with a disorganised file manager :o) lived with it this long, lol. The ones I really wanted to remove from the first page are the ones I use for banners, so I already have them, just didnt want to scroll through so many of them. Really wish this function didnt have to keep copying everytime I use in banner, I have many pages so all have banner, so of course I've got tons of copies of the same thing. Thanks LU!
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
If you want to remove the extra banners, are you not able to select them and delete them?
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Yes, but I recieve a msg that if I delete image, it will be deleted in all instances. Actually the egg banner was deleted but, that was my test since I only have that pic in one banner, so no bigie.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I believe that message "it will be deleted in all instances" simply means that if you used that particular file on your site, when you delete it, then it will be gone on your site. However, if you're not even using it on your site, then this should not affect your site at all. You just need to make sure you don't delete the actual image you're using on your site now. So, if you're using egg cropped picture #12, you should be able to delete egg cropped pictures #1-11 without it affecting your site. I hope I am making sense!
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
You are making sense but, as I recall the other night when I deleted on of the egg pics it also deleted in banner. Also since the same name is repeated over and over the only thing that changes is the size, I never know which is the current banner, the 1st or the last, I assume the last. But, one time I played around I lost banner on soo many pages, I'm afraid of a repeat. Also sometimes I have an issue with (dont know how to explain) you have/had the same prob, where you move your mouse and images move around the page, up, down with jsut movement of mouse, remember that problem you were having, same thing here.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I tried on my test site to edit my banner.. and did this a few times. So.. that I'd have a number of copies saved. What I noticed is while my file name itself is the same.. the dimension is not. So.. that's the difference. One banner is slightly smaller than the other. Look at my example:
dandelions2c.jpg.cropped900x125o0,0s902x110.jpg
dandelions2c.jpg.cropped900x125o0,0s902x132.jpg

Take a look at your file names really closely.. and where the numbers are - check to see if they're really the same.

In regards to that whole mouse & image move around problem - I was able to resolve it! I actually uninstalled Firefox, including any add-ons. I didn't keep any bookmark information - did a totally clean uninstall. Then, I installed Firefox again and my problems cleared right up. Perhaps this is something that you can try? I have a feeling that is what the problem may be. I also think this may be contributing to your inability to rename your file. I had no problems renaming one of my cropped files.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Yes, you are absolutely right, I mentioned above that the only change is size but, which would be most current? Take a look at pic #3 you see the size changes but, which is the most current the size goes from high to low to high to low etc. So I just dont delete all though I would love to be able to get rid of so many repeated images. Logic would tell me that the last would be most current, again I get thrown off by the extreme various sizes.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I see what you mean. Okay..try this...

Go to "preview page". Then, right-click on your mouse button. If you're on Firefox, click on view page source. If you're on IE, click on view source. Look for this: <div id="sys_banner" name="banner" style="background-image:url(resources/dandelions2c.jpg.cropped900x125o0%2C0s883x122.jpg);" > This should be near the top.

This will tell you which image file you're using for your banner. For me.. it's dandelions2c.jpg.cropped900x125o0%2C0s883x122.jpg.

So.. delete all your other images except for that one you found in your page source.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I gotta hit the sack... but let me know if this works out for you. Sorry there's no easy way to go about this. Hopefully Yola employee will take note of this and try some changes to make this a bit easier.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
I tried your suggestion, here are a couple fo results;
" IMG_0029a_edited.PNG.cropped978x263o406%2C-68s584x389.PNG)" but still really doesn't tell me much since they will all be 978x263 due to the banner aspect ratio, all will be named the same as well as I'm not changing name, I'm just using in different pages.
another, " IMG_0003.JPG.cropped978x263o383%2C-160s673x499.png)
OK, just noticed that the last number is different, the 673x499 one was easy to spot since I only had 6 of the same image. I do have one that has 85 aspects of the image so with that that may be a bit tedious. Kinda frustrating because just editing the banner makes a copy......Oh well, not a biggie, extremely cluttered but not a biggie! Thanks LU! I will try unistalling FF and see if that helps the other problem.
Btw, wish me luck and strength 24 hours without a cigarrette........omg I sooooo want one right about now and in 10 minutes then 30 minutes from now! :o) :o(
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I'm rooting for you Rizan! Let me know how it goes!!!
Photo of Kent T Carter

Kent T Carter

  • 230 Posts
  • 3 Reply Likes
Nice clean, and simple tutorial!