What are widget id189 and widget id187 ?

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
What are widget id189 and widget id187 ???....

When i post on my blog - it says things like -



My blog is : http://pen4petroleum.yolasite.com/oil...

Please help ..

Thanks
Shahzad
Photo of Shahzad

Shahzad

  • 18 Posts
  • 0 Reply Likes
  • in a fiX

Posted 8 years ago

  • 1
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Hi Shahzad,

These will be some of your HTML Widgets, you will notice they have gone missing from your page in the Sitebuilder. They probably had incorrect HTML which the Sitebuilder detected and deleted.

More details about whether these are HTML Widgets that are missing would help, and posting the HTML (start with <!--- and finish with ---> to stop the forum from 'actioning' the code)

Andi.
Photo of Jean

Jean

  • 134 Posts
  • 14 Reply Likes
Shahzad, You may be misreading the error messages. They are I87 and I89, not 187 and 189.The first digit is the letter, "I", not the number, "1".
Photo of Shahzad

Shahzad

  • 18 Posts
  • 0 Reply Likes
Thanks for the clarification - But that doesn't change the problem !!!
Photo of Brianna

Brianna

  • 2045 Posts
  • 92 Reply Likes
Hello Shahzad,

You could receive a message like this "Invalid Component id '134'. Cannot Find Component HTML" if:

1. You have pasted some HTML onto your page that is not valid. This often happens if you accidentally miss a portion of the code and a tag is not closed.
2. You have copied and pasted some text from MS Word that has introduced problematic HTML or CSS.

The best way to avoid this is to first copy and paste into a program like Notepad (you'll find it in the Accessories folder of your computer) This will strip out any unwanted formatting and you can then safely paste into the Text Widget.

If you get a message like this, hold down the escape key (ESC) until it goes away. Then try to delete any widget that you think might contain problematic HTML or text copied and pasted from MS Word.

If this does not work, unfortunately you will have to rebuild the page. One thing you can do is save a copy of your pages by clicking on the drop down arrow next to the "save" button and selecting "save page as". This will give you a back up version of your page in case something goes wrong. Remember to untick the box that says "include in navigation" so that the back up page does not appear in your main navigation.
Photo of Shahzad

Shahzad

  • 18 Posts
  • 0 Reply Likes
Thanks Brianna & others...

I recall copy pasting some text from MS word - It might have caused the problem. By the way I have already created a new page.

It was good to know that using MS word can cause such a problem so I will be more alert the next time I use it.

Thanks for your help. I am really amazed by the problem solving skills of Yola team.

Just an out of topic Question:-
How do you attack a problem asked - Do you guess it based on some basic knowledge or Did you face such problems earlier and know the possible reasons ??

Thanks again
Shahzad
www.pen4petroleum.yolasite.com
Photo of Brianna

Brianna

  • 2045 Posts
  • 92 Reply Likes
Hi Shahzad,

Thanks for the update and kind words! If you do recall pasting content from MS word or a different environment with rich text, I would suggest stripping it away a.s.a.p! You can do this by copying it from your sitebuilder into a notepad or text edit and making it plain text (as opposed to rich text). Even if you do not have the page in you navigation, but it is still on your site, there is a chance that errors will still arise.

A lot of the queries asked are quite common 'computer knowledge' that we have been trained on how to respond and what the cause(s) could be. However, we do test every issue that is brought up to help pinpoint the cause and provide a solution. Copying and pasting MSO is a very common error and the results would be the case with any browser-based text editor you might use, not just Yola. It is a universal website building problem.

Certainly give us a shout should you need further assistance down the road!