Why Can't I View Single Blog Posts On My Site? 404 error

  • 1
  • Question
  • Updated 9 years ago
  • Answered
I download and publish my site with a 3rd party host - on my blogs when i click a post heading in order to view the post on It's individual page i get a 404 error message - why is this? Please Help.

Thanks.
Photo of Jim

Jim

  • 13 Posts
  • 1 Reply Like

Posted 9 years ago

  • 1
Photo of Peter

Peter

  • 2569 Posts
  • 113 Reply Likes
Hello Jim,

I don't know the answer to this but I can suggest that you copy the address of an individual blog post heading. and then paste it into your browser bar or into notepad. Just inspect it to see what it's giving you.

All the Yola blog posts are discrete URL's

My posts give the format:

{http://mysite.com/blog page name/blog-post-name-} This is then addressable from the address bar and will take me to the specific URL
Photo of Jim

Jim

  • 13 Posts
  • 1 Reply Like
yea its giving the proper code url - hmm...maybe somthing to do with my ftp or something..I'll let you guys know if I figure it out.
Photo of Peter

Peter

  • 2569 Posts
  • 113 Reply Likes
Jim,

You may like to validate the feed also. Here's a check site to do that:

http://feedvalidator.org
Photo of Jim

Jim

  • 13 Posts
  • 1 Reply Like
Urrrggh I even tried publishing through yola and im still getting the not found error grrrr... can anyone help?
Photo of Peter

Peter

  • 2569 Posts
  • 113 Reply Likes
Jim,

Can you post your blog URL?
Happy to see what I can find out for you from afar.