Why is a specific Google Adsense unit failing to show up on my page?

  • 1
  • Question
  • Updated 7 years ago
I have Google Adsense units on my page, however, one of them isn't showing up. The code has been there for weeks so it's not an issue of me waiting for it to show. Here's the page:

http://www.fdrhouses.com/moving-resou...

The invisible adsense unit is directly below the email subscription box.
Photo of ncmama05

ncmama05

  • 18 Posts
  • 0 Reply Likes
  • confused

Posted 7 years ago

  • 1
Photo of jeremy

jeremy, Employee

  • 1349 Posts
  • 90 Reply Likes
Hello Ncmama05,

Can you please check to see that you got the correct portion of the code for your adsense widget?

If it is correct and still isn't showing you will need to contact Google Adsense support. You can find their support pages here: Adsense

I hope this helps.
Photo of ncmama05

ncmama05

  • 18 Posts
  • 0 Reply Likes
Okay, I'll contact Google about this. It is so strange in that I put up a test page on yola to test out the code and it immediately showed up. However, in that particular spot on my page I linked to, the code will not show up.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello ncmama05,

It could also be that you have other coding on your page that is interfering with Google's code. From glancing at your site quickly, it seems that you have copied and pasted text from an external source to your page. This could be the source of the problem. To address this, please copy the text and paste into Notepad. This will strip the inherent coding. Then, drag over a new Text Widget, copy and paste your text from Notepad to your Text Widget. Delete the old Text Widget. You will need to use the Text Editing Toolbar to reformat your text and links.
Photo of ncmama05

ncmama05

  • 18 Posts
  • 0 Reply Likes
Thanks Sanja,

I did that using a duplicated test page linked below. It doesn't seem to have done anything at least from what I'm seeing.

I also removed the opt-in form in case that could've been interfering:

http://www.fdrhouses.com/test-page.php
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello ncmama05,

I am still seeing indications of copied and pasted text. Have you also addressed this issue? Please read above to know how to combat this problem. Once that has been resolved, then we can determine if the ad is still not working. I also suggest following through on Jeremy's advice of contacting Google. Hopefully, we can all work together towards a successful resolution.
Photo of ncmama05

ncmama05

  • 18 Posts
  • 0 Reply Likes
Nope, that's not it. I removed everything from that column other than the adsense code and still nothing. I posted on Google's help forum. Not holding my breath for a response there....
Photo of Kevin

Kevin

  • 475 Posts
  • 29 Reply Likes
ncmama05, I think this is Google's problem. I've looked at the banner with developer tools in chrome, and it seems Google is displaying the ad through an iframe, which means it is simply a mini window into their page. However, the source of Google's ad page is blank, so this is Google's problem. You'll just have to wait it out at Google's help forum. This is the ad page that is showing:Here. As you can see, the page is blank.

Sincerely,
Kevin