Why wont it let me change the background on my website Eds3gaming.org

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Dumb site editor wont let me change the background. you updated the editor and now i am un happy
Photo of William Taylor

William Taylor

  • 1 Post
  • 0 Reply Likes
  • Angry

Posted 5 years ago

  • 1
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello William

You chose the Inky Night Premium Style which actually doesn't allow to edit your background. But if you still want it, there is a way to change your background by working with a little CSS code.
  1. Open your File Manager (Sitebuilder > upper menu bar > Site > File Manager), and upload your new background image.

  2. Drag and drop an HTML Widget on the page for which you'd like to change the background.

  3. Add this code to the HTML editor:
    <style type="text/css">
    
    body {
    background-image: url(resources/black-diamond.png);
    }
    </style>

  4. Replace "black-diamond.png" by the file name of your new background image file.

  5. Click on "Save", and check in Preview.

If you want the same background image on all your pages, please follow these steps:
  1. Open your Site CSS Editor (Sitebuilder > lower menu bar > Style > Edit Site CSS).

  2. Uncheck the checkbox at the bottom left.

  3. Clear the whole left box.

  4. Add this code to the left box:
    
    
    body {
    background-image: url(resources/black-diamond.png);
    }

  5. Replace "black-diamond.png" by the file name of your new background image file.

  6. Click on "OK".