Why won't my silverlight control display in Firefox or Internet Explorere, but will in Chrome?

  • 1
  • Question
  • Updated 9 years ago
My site is showing up good in Chrome, Firefox, and Internet Explorer. However one page is having problems in Internet Exporer and Firefox, but not Chrome. I created custom html that would load a Silverlight control I created. I got it working, but I have not been able to figure out why it won't work in Firefox and Internet Explorer. Here is the link to the website I am working on, and the link to the page with the specific problem.

http://brownfamilyreunion.yolasite.com/
http://brownfamilyreunion.yolasite.co...

This is really weird, I just happened to be working in Chrome otherwise I would have thought it impossible to get a Silverlight application to work at all on a Yola site.
Photo of Timothy

Timothy

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 9 years ago

  • 1
Photo of jeremy

jeremy, Employee

  • 1349 Posts
  • 90 Reply Likes
Hello Timothy,

I can't see your silverlight add-on on FF either - it works fine on Chrome though so it doesn't look like bad code.

Unfortunately Silverlight often conflicts with plugins on Firefox and is a bit tempremental. There are a number of forums around this topic such as: http://betaforums.silverlight.net/for... and you can take a look through them to see what you can do to get it working for you.

However please note that if you can't see it now then quite a few other users might not be able to see it.

If you need any further assistance, please let me know.
Photo of Timothy

Timothy

  • 6 Posts
  • 0 Reply Likes
Just to let you know it works on Internet Explorer and Firefox when I test locally on my machine. I am even more confused why this works only in Chrome when I put the custom html on the web page.
Photo of lambofgod

lambofgod

  • 875 Posts
  • 35 Reply Likes
I don't have to much experience with silverlight functions, but I do believe you have to have ActiveX enabled for Silverlight.

Manage to find this is my mountains of bookmarks :)
http://www.ningzhang.org/2010/02/17/s...
Photo of Timothy

Timothy

  • 6 Posts
  • 0 Reply Likes
I have gotten further:
Firefox - other silverlight works, Firefox is downloading it but not running the xap file.

Internet Explorer 6 & 7 run just fine, Internet Explorer 8 only runs it in compatibility mode. I believe this makes it behave like IE7.

I am getting more info, maybe enough to get help on the Silverlight forums. Thanks for the help.