Yola editor is painfully slow or doesn't work

  • 1
  • Question
  • Updated 8 years ago
  • Answered
Yola is PAINFULLY slow to load, and in the past few days I cannot get the editor to load at all, or it seems to freeze when I try to make changes. Has anyone else had this?

I'd like to recommend Yola to clients, but can't if they have the same problems I do.
Photo of rachelq


  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 8 years ago

  • 1
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Thank you for your desire to recommend Yola. I fully understand the difficulty in doing so if the site builder is not performing properly. We pride ourselves in the speed of our site builder, and right now it is working really well from my location (San Francisco) and we are not aware of any global problems. Our host tracking software is also not reporting any problems at this time in specific locations around the world.

However, we would certainly like to investigate this further. Can you tell me:
1) Where you are located?
2) What browser and operating system you are using?
3) How you are connecting to the internet? (eg, from home, work, school etc. and what connection speed you have)
4) The domain name of your site if it is published?
5) If you recently added any custom code, or copied and pasted any text from an external source such as MS Word.

The answer to the above questions will really help me to figure out if this is a problem with the site builder in general, or a problem in specific environments. It could also be caused by some content that is specific to your site, so the more detail you can give me the better.

We would like to have everything functioning smoothly for you so that you can edit your site successfully and recommend Yola to your clients!
Photo of Alex


  • 3448 Posts
  • 39 Reply Likes
its a bit slow for me to,

im in The North East of the UK

im in IE 7

im at home wireless

is that enough?



it has been slow for about 3 days.
Photo of KanThaiDecor


  • 2402 Posts
  • 263 Reply Likes
Has been fine here in the USA where I am
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
If your using Vista... service pack 2 is being launched - its quite a large download on a slow connection, might be getting in the way of things.

If your not try a general clean up of your browser.
Photo of Boomer

Boomer, Champion

  • 2055 Posts
  • 84 Reply Likes
Working hundreds for me here in (what's supposed to be) Sunny South Africa.
Photo of rachelq


  • 2 Posts
  • 0 Reply Likes
Thanks for all the input. I have Vista with the latest service pack. I try it on FireFox and explorer and all I get is the red "Loading Yola" bar. I tried it on my Mac and it seems to work fine.

Guess it's one of those "it's not you, it's me scenarios."
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
I am glad to hear that it is working for you on your Mac. Have you tried clearing the cache on your Vista machine? The other option is to reinstall your browser to see if this helps.