Yola Site Publishing Errors

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
Why does my website not publish data correctly? I get access to pages I have previously hidden and password protected and I get 404 error's quite a lot. I have password protected two pages 'Contact Us' and 'The Team' and they aren't supposed to be visible in the navigation. When you first go onto the site 'Home' and 'Blog' should only be seen. That is how it's supposed to be, but when you click between them more pages appear on the site map. They are password protected, but I don't want them to show. Any help? My site is http://www.mediocregames.co.uk
Please help quickly!
Photo of Mediocre Games

Mediocre Games

  • 13 Posts
  • 0 Reply Likes
  • confused, frustrated and angry!

Posted 7 years ago

  • 1
Photo of Mediocre Games

Mediocre Games

  • 13 Posts
  • 0 Reply Likes
It seems to be going back to previous published versions of the site also. It is very confusing. I have re-logged, cleared my cache and even restarted my computer to see if it was to do with me, but it isn't. Thanks again.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello Mediocre Games,

To hide your pages from the navigation, please follow the steps given below:

1. Click on "Page" > "Page Manager" in the main menu.
2. The Page Manager will open and you will see the list of your pages.
3. To remove pages from your navigation, you need to click on the green check for the page that you would like to remove. This check is located next to the green "indent" arrow to the right of each page name (if you mouse over it, you will see the words "Click here to hide this in your menu").
4. Click on the green check, so it becomes a red "x". This removes it from your navigation.
5. Click "OK" and save your changes.

Don't forget to click on the "Publish to the web" button to update your website.

Please let me know how this goes.
Photo of Mediocre Games

Mediocre Games

  • 13 Posts
  • 0 Reply Likes
The thing is, I was doing that. Sometimes the pages would hide but when I would navigate to another it would unhide! But thanks anyway.
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Hi Mediocre Games

Thank you for the update. I have tested on my site, but I'm unable to replicate the problem. I've taken a look at your website (http://www.mediocregames.co.uk/) and I see that the pages "Contact Us" and "The Team" are displaying in the menu.

Are these currently hidden as subpages in your Sitebuilder? Have you tried republished your site to see if that helps?

Nazlie
Photo of Mediocre Games

Mediocre Games

  • 13 Posts
  • 0 Reply Likes
I still couldn't get it to work so I decided to not hide the pages and just change the whole layout of the navigation altogether. It works fine now. Thanks for your help!
Mediocre Games
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Thanks for the update. I'm happy to hear that you found a workaround for the problem.

Happy Holidays!
Photo of Mediocre Games

Mediocre Games

  • 13 Posts
  • 0 Reply Likes
No, thank you for all the help! And have a nice holiday also!